Using an IDE

This topic describes how to use xds-gdb from within an Interactive Development Environment (IDE) to debug your application. The topic uses the NetBeans IDE as an example.

Prerequisites

Before using the IDE, you need to declare the project you want to debug on the xds-server.

NOTE:

The project you declare can also have been built using XDS. For information on building the project using XDS, see the “Create your first AGL application” section.

NetBeans

This section presents an example using NetBeans version 8.x:

  1. Select the Options item in the Tools menu.

  2. Open the Build Tools tab.

  3. Open the C/C++ tab and click the Add button to reveal the “Add New Tool Collection” dialog box:

    Add new tool panel

  4. Fill in the Make Command and Debugger Command fields so that they point to the XDS tools. Following is an example:

    Add new tool panel

  5. Click on OK button.

  6. Select the Project Properties item in the File menu to update your debug settings.

  7. In the “Project Properties” dialog, be sure that the “Gen3 board” appears in the “Configuration” field (i.e. active).

  8. In the “Categories” navigation pane, select Run.

  9. Set the following:

    • Run Command: target/start-on-root@renesas-gen3.sh NOTE:

      The script name could depend on the RSYNC_TARGET variable you set in pre-build command.

    • Run Directory: build_gen3

  10. In the “Categories” navigation pane, select Debug.

  11. Set the following:

    • Debug command: /bin/true

    • Working Directory: Leave this field blank

    • Gdb Init File: target/gdb-on-root@renesas-gen3.ini NOTE:

      The script name could depend on the RSYNC_TARGET variable you set in pre-build command.

      Select Model panel

  12. Click Apply.

  13. Click OK to save your settings.

  14. Start debugging your application by selecting the Debug Project item in the Debug menu, or by entering the CTRL+F5 shortcut.